« 頭の中は何で一杯か | トップページ | 落日燃ゆ »

2007年11月10日 (土)

solarisでflightgear

ここからflightgearとflightgear_baseをpkg-getしてみました!http://www.blastwave.org/packages.php

いざ起動しようとすると以下のエラー
bash-3.00# fgfs
Base package check failed ... Found version 0.9.10 at: /opt/csw/share/FlightGear/data
Please upgrade to version: 0.9.9
bash-3.00#
なんかベースパッケージの方がバージョンが上みたいです。いけないとは思いつつ/opt/csw/share/FlightGear/dataのversionの中身を0.9.9に書き換えてしまって起動すると

Fgfs2

一瞬動くように見えたんですが、駄目。。。

Fgfs

cfgファイルがちょっと違うみたいです。バレてますね(笑)

次にここから、0.9.9きてみました。
ftp://ftp.planetmirror.com/pub/fgfs/Shared/

そして、いざ起動してみると動き出しました。

bash-3.00# fgfs
opening file: /opt/csw/share/FlightGear/data/Navaids/carrier_nav.dat
/opt/csw/share/FlightGear/data/Navaids/TACAN_freq.dat
solaris_native: opening /dev/audio
Opened /dev/audio successfully
Setting audio device...
Initialising callsign using 'Aircraft/c172p/Models/c172p.xml'
Initializing Nasal Electrical System

Fgfs3

動きがモッサリです。どうも原因はこのエラーメッセージにありそうです。
Assertion failed: fgState.Initialised, file freeglut_cursor.c, line 86
nvidiaのGLUTとは互換性無いんですかね?

でも本当はこんな事しててはいけないのです。昨日solaris勉強しようと思って東京駅近くの本屋に行ったのですが、何やらすごい人、人、人!大丸が新しくなってグラントウキョウノースタワーに入って地下で八重洲地下街とつながってさらにサウスタワーにもつながって地下のオシャレな飲食店が色々入ってます。それで終点がパシフィックセンチュリープレイス丸の内なんです。ついついこっちの方が面白くて歩き疲れてお腹が空いて八重洲地下街で「プルコギ入り石焼きビビンバ」食って帰りました。情けない。。

おじさん老いやすく疲れやすいしお腹も空くし学なりがたし

私の個人的希望ですが、さらに有楽町のガード下の飲み屋さんまで地下でつながって終点がビックカメラ有楽町店になって、東京メトロ有楽町線に乗り換え出来るなんて事になったらとっても便利だと思うのですが。若い部下を連れて飲みに行くときはオシャレに!おじさん同士もしくは相手が鬼奥さんの場合は、ガード下で台湾ビール。八重洲界隈のサラリーマンの皆さん如何でしょうか?


|

« 頭の中は何で一杯か | トップページ | 落日燃ゆ »

solaris」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック


この記事へのトラックバック一覧です: solarisでflightgear:

« 頭の中は何で一杯か | トップページ | 落日燃ゆ »