カテゴリー「Linux」の記事

2013年6月22日 (土)

~ SONY Tablet S その後 ~

去年の夏に手に入れてから、出張のお供に連れ回しておりまして

最初のうちは、とても珍しがられて「SONY?」ってな感じでしたが

先日、電車で隣に座っている人が持っていた「Xperia Tablet」を見た途端

薄さに驚いてしまいました(笑)

暫くイジリ倒してないので、ちょっと暇つぶしに攻撃をかけてみました!

「4.0.3 release5a」に上げてしまったら、rootが取れないというのは、以前から

認識してたのですが、最近出来そうだというのをあちらこちらで見かけまして

http://qua1ia.blogspot.jp/2013/05/get-root-on-sony-tablet-p-ics-r5a.html

http://forum.xda-developers.com/showthread.php?t=1515720

参考にさせて頂きました。感謝です!

S.onyTablet.S [ALLinONE] v6.4を使って

[*] Before continuing, ensure USB debugging is enabled, that ADB
[*] is working properly, and that your tablet is connected via USB.
[*] You've got to have proper MPT driver to root your tab!
[*] (MTP wpdmtp.inf included, or use great Bluechips drivers!)

[*] WARNING: This exploit may result in wiping your /data partition,
[*] causing you to lose any applications and data on your tablet.
[*] There should be no risk of permanent damage to your device, but
[*] by running this script you accept all responsibility.

[*] Press any key to agree and continue...

[*] Waiting for device...

     *******************************************
     * R5A fw detected, using new root method! *
     *******************************************

[*] Waiting for device...
[*] Device found.
[*] Pushing exploit...
[*] Pushing root tools...
[*] Rooting tablet...
[*] Cleaning up...
[*] Rebooting...

[*] Exploit complete!
[*] Press any key to continue.

Supersu

無事成功です!

Clock

いや~さすがに時代遅れですかね、、、、

Supersu2

| | コメント (0) | トラックバック (0)

2012年7月29日 (日)

~ sony tablet Sシリーズ お買い上げ ~

夏のボーナスで、半年間頑張った自分にご褒美と勝手に決め込みましたが

かなりの品薄状態。。

まずは近場へということで、7月20日に都内某所のサラリーマン御用達のビックカメラへ。

ソニーのタブレットのブースがあって、かなり期待出来そう!!

販促のお兄さんに、在庫在りますか?って聞いたら「32GBモデルが現在5台です!」

早速初期不良じゃないヤツ(笑)を1台持ってきてください!

販促員さん:パソコンと違うじゃないかって返品したいって言う人居るんですけど

私:android(Linux)でしょ?、その先は言わず(うふふ)

Android3

でもって早速何をしたかというと、、、

Sonytablet02_2

スクリーンキャプチヤー出来ました。

Tablet04

こちらを参考にさせて頂きました。感謝

http://moon.ap.teacup.com/shelter9/178.html

DOS窓でコマンド打ち込むんですが、\と/がごっちゃになってしまって(笑)

adb.exeや、ddms.batの入ってるホルダーがすぐに見つからず(笑)

adb_usb.iniは、

C:\Users\ユーザー名\.android

android-sdkは

C:\Users\ユーザー名\AppData\Local\Android

以上に鎮座してます。

Ddms

だんだん危険な領域に近づきつつ。。。。

その後、、、何やらオプション品までが品薄になりつつある気配でしたので

クレードルを求めて、仕事帰りにアキバへ散策

ツクモでバッファローの液晶保護シートが格安なので2枚ゲット、しかし

クレードルは見つからず。

最後の期待をこめて、汗をかきかきヨドバシへ(末広町からだとちょっと遠い)

Cradle

歩いた甲斐あって980円でゲット!そのままJRでご帰宅

| | コメント (0) | トラックバック (0)

2012年1月22日 (日)

~ Gentoo マザーとCPU交換 ~

ついに私は、「AMD」一筋からintelに乗り換えました。

AMDには思い入れが沢山ありましたが、引き続き頑張って欲しいです!

CPU:PhenomII 1090T → core i7 2600K

MB :M4A78pro → P8Z68-V/Gen3

メモリ:DDR2 4GB → DDR3 8GB(4G X 2)

VGA:N560GTX-Ti Twin Frozr II OC(変わらず)

いきなり、旧環境のまま動かしたらどうなるか?やってみたところ

動きましたが、カーネルをインテル用に再構築した(つもり)でしたが、

結果は、、、ネットワークが変になりました。

最初は接続されますが、すぐに切断されます。ログには、

e1000 irq19 disable みたいなメッセージ

思い切って最新のカーネルで旧環境を引き継がずにやってみたら旨くいきました。

ただし、make.confの

CFLAGS="-march=core2 -O2 -pipe"

設定が合ってるか、まったく自信無いです(笑)

Kernel01

CPUはcore2以降にして

Kernel02

センサーチップは、winbondのそれらしきヤツを有効にしました。

Nct6776

結果的には、NCT6776が当たりだったようです。チップはnuvotonですが

そもそもは、winbondの子会社で、結局はwinbondなんですね、紛らわしい

Ondemand

無事に、オンデマンドガバナで動きました!(HTTはオフにします)

あとCompizを有効にしていると、ターミナルの動作が変(make menuconfigの時とか)

これは、conpiz-manager の以下の行を訂正すると直りました。

ソースは失念

build_args()
{
if [ $INDIRECT = "yes" ]; then
  COMPIZ_OPTIONS="$COMPIZ_OPTIONS --indirect-rendering "
fi
if check_nvidia; then
  #COMPIZ_OPTIONS="$COMPIZ_OPTIONS --loose-binding"
  COMPIZ_OPTIONS="$COMPIZ_OPTIONS"
fi
}

以上です!

| | コメント (0) | トラックバック (0)

2011年12月18日 (日)

第2弾! 懲りもせずに、gentooに勝負を挑む!

前回、XFCE4で旨く言ったので、今度はgnomeのインストールに挑戦しましたが、、、

メニュー(アイコン)が出てこないです。。。

Gnome01

バグで、以下を.xinitrcに書けば良いということは分かったのですが、

export XDG_MENU_PREFIX=gnome-

一番先頭に書いたら、旨く行きました。これに気が付くまで1週間かかりました(笑)

私の.xinitrc ゴチャゴチャで済みません。
export XDG_MENU_PREFIX=gnome-
export LANG=ja_JP.UTF-8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
scim -d
exec startxfce4
#exec gnome-session
#exec gnome-session
#exec startkde
#setxkbmap -rules evdev -layout jp -model jp106

Gnome02_2

無事に出てきました!

KDEは、旨くemerge出来なかったのでしばらく放置してportageの更新待ち。

先日やったら出来ました!旨くいかない時は「待っている」のが正解ですね。

Kde

追伸:何故か今回、fsckが頻繁に起きてハードディスクが死にかけていると

思ってました。コンパイルの途中で「readonlyなので書き込めない」というような

メッセージが多発しましたが、結局SATAケーブル取り替えたらピタッと消えました。

| | コメント (0) | トラックバック (0)

2011年12月 1日 (木)

懲りもせずに、gentooに勝負を挑む!

しばらく、サボっていたのでちょっとgentooでもいじってみようかと思い立ち、

まあ、とてつもなく色々と遊んでいたら運の尽き。。。。

うんともすんとも言わなくなってしまうほどイジリ倒して、

Live CD で立ち上げて、fdisk /sdaと打ち込んでいる自分がいる(笑)

やり始めて、丸々1週間、ここまで来るのに長い道のり!!

とでも一言では言い表せません(涙)

Gentoo01

こんな状態にするのに、長いこと。。。

nvidia-driversが何としてもロード出来ないのです、deviceが無いって怒られます。

思わす、ケースを開けて、自分のビデオカードが560tiだって確かめました(笑)

思い立って、nvidiaのサイトからNVIDIA-Linux-x86_64-285.05.09.runを落としてきて

こいつを使ったら、ようやく出来ました!、いったい何なんでしょうかね?

その後、やっとこさxfce4を入れてここでまたトラブル!

いつも使っている「scim-anthy」がreafpadでは使えるのにfirefoxで動きません!

日本語wikiを何度見直しても駄目!

しかし神のご加護が。。。

------------------------------

# ChangeLog for app-i18n/scim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.147 2011/11/17 09:06:46 naota Exp $

*scim-1.4.11-r1 (17 Nov 2011)

  17 Nov 2011; Naohiro Aota <naota@gentoo.org> +scim-1.4.11-r1.ebuild,
  +files/scim-1.4.11-type-module-use.patch:
  Add patch to make it work with Firefox and Thunderbird. Bug #390053
# ChangeLog for app-i18n/scim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.147 2011/11/17 09:06:46 naota Exp $

----------------------------
バグだー!!!!!!!!!!!!!!!!!!

以下の通り、scim-1.4.11-r1 に上げて解決!

tux ~ # scim --help
Smart Common Input Method 1.4.11

Usage: scim [option]...  以下省略

Xorgも新しくなりました。106キーボードは旨く設定できません。

xfce4側で、選択中

tux ~ # Xorg -version

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0.6-gentoo x86_64 Gentoo
Current Operating System: Linux tux 3.1.1-gentoo #2 SMP Thu Dec 1 21:32:09 JST 2011 x86_64
Kernel command line: root=/dev/sda3
Build Date: 23 November 2011  06:14:48PM

Gentoo03

実はまだ、CD-ROMもいちいちコマンド打ってマウントしてます。

恐るべし!、くれぐれも近寄らないように(仲良くなれれば最高!)

続く

| | コメント (0) | トラックバック (0)

2010年9月10日 (金)

 gentooはついに我を見離したか?

gentooの神々は私に試練のお与えになりました。

xorg-1.7から始まり、試練の道のりを歩いてきました!

何かの拍子に、cdromのトレイが開かなくなってしまい正確に表現すると、

イジェクトボタンを押すと一旦開いてすぐ閉まってしまいます。

小人が住んでいてイジェクトボタンを押しているかのような。。。。

心配になってケース開けて中に小人が居ないか調べました。

冗談はさておき、普通なら/dev以下にcdromが出来るのですが見当たりま

せん。

/dev/hdb(ide接続なので)手動でリンクを貼っても再起動すると消えて無くなります。

udevが何か悪戯しているらしいのは想像出来るのですがネットで色々調べてもこれ

といった原因が掴めませんでした。

最近のカーネルの設定は、sataを標準に設定されている程度にしか

考えていませんでした。

そしてついに、神は私にヒントを与えて下さった。

* Checking for suitable kernel configuration options...
*   CONFIG_IDE=y should not be set. But it is.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
*
* udev-151 does not support Linux kernel before version 2.6.25!
* For a reliable udev, use at least kernel 2.6.27

* Your kernel version (2.6.35-gentoo-r5) is new enough to run udev-151 reliably.

でもCONFIG_IDE=yってideのドライブ使ってるから常識だろうって
思ってましたが。。。。。

<*> ATA/ATAPI/MFM/RLL support (DEPRECATED)  --->

CONFIG_IDE:
If you say Y here, your kernel will be able to manage
ATA/(E)IDE and ATAPI units.
The most common cases are IDE hard drives and ATAPI
CD-ROM drives.
This subsystem is currently in maintenance mode with
only bug fix changes applied.
Users of ATA hardware are encouraged to migrate to
the newer ATA subsystem ("Serial ATA (prod) and Parallel
ATA (experimental) drivers") which is more actively
maintained.
擁するに、こっちはあんまりメンテされないからata使う奴はこっち使えと!

<*> Serial ATA and Parallel ATA drivers  --->

私のマザーは、M4A78-PROなので、AMDとATIを有効にしてカーネルを

再コンパイルしました。

<*>AMD/NVidia PATA support
< >ARTOP 6210/6260 PATA support
<*>ATI PATA support

そして再起動!、、、、ですがカーネルパニック!!

でもメッセージ見ると、

sda1、sda2、sda3の文字が。/dev/hda3=rootが無いぜ!ってもしかして

sataで認識しているのかも。

失敗すれば、インストールディスクで起こせば平気ってな感じで

grub.confを以下のとおりhda3→sda3

kernel /boot/kernel-2.6.35-gentoo-r5 root=/dev/sda3 acpi_enforce_resources=lax

fstabもsata仕様に書き直しました!

/dev/sda1    /boot    ext2        noatime     0 1
/dev/sda3    /        ext3        noatime     0 1
/dev/sda2   none      swap        sw         0 0
/dev/cdrom  /mnt/cdrom    auto    noauto,ro   0 0

結果は、神の思し召しがありました。

tux ~ # ls /dev/cd*
/dev/cdrom1  /dev/cdrw1
tux ~ # ls -l /dev/cd*
lrwxrwxrwx 1 root root 3 2010-09-11 07:32 /dev/cdrom1 -> sr0
lrwxrwxrwx 1 root root 3 2010-09-11 07:32 /dev/cdrw1 -> sr0
tux ~ #

Devcdrom1

良かった!、/dev/cdrom1が出来てる!!

只今を持って、小人は旅に出かけました、、時々は遊びに来て下さい。

大人になって、綺麗なお姉さんになって。。。。大歓迎!

お土産は、sataのドライブとリムーバブルケース。

出来ればREX-SATAの白が嬉しい(笑)この辺とかが参考に。

http://forums.gentoo.org/viewtopic-t-813595.html

Cube

http://en.gentoo-wiki.com/wiki/Compiz-Fusion

最後はここを参考に、compizを動かしてます。

何となく、気が付いたのですが、キューブを有功にして、透明を設定すると途端に、CPUの使用率が上がりますので無効にしてます。

Cubutoumei

| | コメント (0) | トラックバック (0)

2010年8月27日 (金)

~ gentooが熱い その2 ~

何か納得いかないところがありまして、キーボードのレイアウトを

halが見つけてきてくれません。

/etc/hal/fdi/policy/に、10-keymap.fdiを置いて、

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">jp106</merge>
      </match>

      <merge key="input.xkb.layout" type="string">jp</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

としてるのですが、、、、

今のxorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.44  (buildmeister@builder103.nvidia.com)  Thu Jul 29 01:52:55 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
#   Option     "XkbModel" "jp106"
#   Option     "XkbLayout" "jp"
#   Option       "Protocol" "Standard"
#   Option       "CoreKeyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

此処では、コメントアウト(赤字)して、KDEの設定で日本語キーボードを

選んでます。

Jp106

人間、あきらめが肝心とか。。。

tux ~ # Xorg -version

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.35-gentoo-r1 x86_64
Current Operating System: Linux tux 2.6.35-gentoo-r1 #5 SMP Sun Aug 22 13:24:05 JST 2010 x86_64
Kernel command line: root=/dev/hda3 acpi_enforce_resources=lax
Build Date: 27 August 2010  08:59:58PM

Current version of pixman: 0.18.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
tux ~ #

make,confには、

INPUT_DEVICES="evdev"

VIDEO_CARDS="nvidia"

を書いてあるしな。。。。。。

恐るべし!Xorg 1.7.7

| | コメント (0) | トラックバック (0)

2010年8月21日 (土)

~ gentooが熱い ~

夏休みの間、お金が掛からずに一日暇つぶし出来る事って何かなと

考えてみたところ、、思い付きました!gentooをインストールすることです。

余っているIDEのHDD繋いでと。。

Gentoostage

ここまでは順調!、何だこの調子だと半日ぐらいしか遊べないじゃないか。。

インストールはそのまま無事に完了して、再起動!

うわ~~~~~~~いきなりエラー!!!!!!

rootのパーテーションが見つからないって嘘でしょう?慌てず、インストールディスクで

起動して、fstabを確認します。

/dev/hda1  /boot  ext2  noatime 1 2
/dev/hda3  /        ext3  noatime  0 1
/dev/hda2  none   swap  sw        0 0
/dev/cdrom  /mnt/cdrom auto  noauto,ro 0 0
#/dev/fd0  /mnt/floppy auto  noauto  0 0

私はめんどくさいので/bootを最初からマウントしてしまいます。

何ででしょうか???

以下は、Xが動き出してからスクリーンショット撮ってます、念のため。

Kernelata

ATA関係のモジュールが外れてました。そんな殺生な事しないで欲しい!

インストールディスクは使えているのに。。

いくらSATAが主流になったからってね。

あと、/bootがマウント出来ません!、

Kernelext2

これも散々調べて、結論は単にext2はもう使わないから外してあるらしい。

second extended fs supportを有効に。

install docには例として使ってるでしょう、、、ちょっと意地悪

気を取り直して、Xorgを入れます。

前回Xorg1.5で泥沼にはまってますけど、

http://sky-captain.cocolog-nifty.com/blog/2009/05/gentoo-xorg-15-.html

http://sky-captain.cocolog-nifty.com/blog/2009/05/gentoo-xorg-1-1.html

すでに経験済みですからと思いきや再びXorgは進化を遂げて、1.7へ

Xorg -configure して、その設定でstartxすると真っ黒!、キーも受け付けず

やむなくリセットです。

nvidia-xconfig使った方が旨く行くようです。どっちもXは動きませんが。。。

(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)

dri、dri2、kbd、mouse この4つモジュールが見つからない。

以下はX関係。

/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found

dri、dri2は無視して平気みたいな事が書いてありまして、

マウスとキーボードは、必死に情報探してやっと以下にて解決

emerge xf86-input-mouse xf86-input-keyboard

twm、xclock、xtermは単純に

emerge twm xclock xterm

Xorg

やっとこさ、X-serverが動いて、KDEをemerge中です。

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml

でももうすぐ、xorg1.8がやってくるみたい。halは使わないらしい。

今回、キーボードのレイアウトはxorg.confに書きました。

Option    "XkbModel"  "jp106"

Option    "XkbLayout" "jp"

Kde01

終わった!、夏休みはとっくに過ぎて良い暇つぶしになった。

あと、lm_sensersで温度や、ファンの回転数がとれないときは、

ブート時のオプション acpi_enforce_resources=lax です。

www.muhri.net/gkrellm/  つながらなくなってしまった。

Kde02

gentooは、半年に一度くらいインストールをしていないと時代遅れに

なってしまいます。

xorg1.5で罠に落ちた私は、なぜか1.7でも自ら進んで罠に。。

こんなに苦労するのになぜ挑戦するのか?

動いたときの達成感が違うんですね!!!

次へを数回クリックして、ユーザー名とパスワードを設定したら

後はお任せ!じゃ寂しいでしょう?

| | コメント (0) | トラックバック (0)

2009年5月 5日 (火)

gentoo xorg 1.5 泥沼から片足脱出

genomeから使い慣れたxfce4に切り替えまして、どうしてももう一度keymapのところを何とかしてみたいという衝動に。。

私の場合、.xinitrcに以下のコマンドを書いていましたが、
setxkbmap -rules evdev -layout jp -model jp106

こちらから頂いた、
http://freebsd.xo-ox.net/x11/xorgconfnv160

10-keyboard-jp106.fdiを /etc/hal/fdi/policyにコピーしたら無事完了となりました。助かりました、感謝です。
内容は以下のとおり。

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keyboard">
<merge key="input.x11_options.XkbRules" type="string">xorg</merge>
<merge key="input.x11_options.XkbModel" type="string">jp106</merge>
<merge key="input.x11_options.XkbLayout" type="string">jp</merge>
</match>
</device>
</deviceinfo>

お陰様で、"[" や "]" が正しく入力できるようになりました。

tux ~ # ls -l /etc/hal/fdi/policy/
-rw-r--r-- 1 root root 367 2009-05-05 14:33 10-keyboard-jp106.fdi
-rw-r--r-- 1 root root 367 2009-05-04 16:08 10-keyboard-jp106.fdi-back
-rw-r--r-- 1 root root 919 2009-05-05 13:03 10-keymap.fdi--
-rw-r--r-- 1 root root 892 2009-05-04 15:53 10-keymap.fdi~~
tux ~ #

カーネルも2.6.29-gentoo-r2に上げてます。

tux ~ # uname -a
Linux tux 2.6.29-gentoo-r2 #1 SMP Tue May 5 12:22:06 JST 2009 x86_64 AMD Phenom(tm) II X4 920 Processor AuthenticAMD GNU/Linux
tux ~ #

Compiz

Compiz2

何はともあれ、ここまでたどり着きました!最初はウインドウがドラッグ出来なくて焦りましたが、なんとcompizConfigマネージャで「ウインドウの移動」、「ウインドウのサイズ変更」にチェックが入っていませんでした。焦りました。

| | コメント (0) | トラックバック (0)

2009年5月 3日 (日)

gentoo xorg 1.5 泥沼にハマる

連休で暇だったのと、余ってるHDDがあったんでgentoo2008.0を入れてみました。
密かに新しいビデオカードを狙ってまして、ATIなら4850、nvidiaだったらGTS250が乗っかったヤツにしようと。。であるならば、今のマザーのオンボードのAMD780Gでgentooが動くかどうかなどと言うバカな考えを持ったのが運のツキでした。

実はつい最近ある事情でマザー交換しました。

ASUS M4a78-PROです。オンボードのNICはいつも通り殺しておいて、安心確実な

Intel(R) PRO/1000

AMD Phenom(tm) II X4 920 Processor stepping 02

nVidia Corporation GeForce 8600 GT

構成は以上な感じ。。

いつも通り、ここを見ながらルンルン気分で楽勝と思いつつお決まりの

http://www.gentoo.org/doc/en/xorg-config.xmlmake.confに、

INPUT_DEVICES="keyboard mouse"

VIDEO_CARDS="nvidia" または、VIDEO_CARDS="fglrx"

これで emerge xorg-x11

あとは、xorgconfigでxorg.confを作ってあげて、driverにnvidiaと書けばと思いきや。。。。

ここから泥沼にどっぷりと浸かってしまった。

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml

どうやら、xorgの仕様が変更になったらしくカーネル設定で以下を有効にせよと。これは最初から設定OKでした。

Device Drivers --->Input device support

--->--- Input device support[*]     Event interface

次に make.confに以下を記載せよと

INPUT_DEVICES="evdev"

さらに、halが自動でインプットデバイスをホットプラグすると。

Xorg now supports HAL to automatically hot-plug input devices

さらに、これは言い過ぎ! xorg.confが無くても動くって!

Even better, try running Xorg without any xorg.conf (you can rename it to xorg.conf.old)

試しに、xorg.conf消して起動したら、nvを捜しに行ってXは起動せず。

色々調べてみたら、xorg.confのキーマップは記載しても無視される見たいです。

とりあえずここだけは今までどおりに書きました。

Section "Device"

   Identifier  "nvidia"

  Driver      "nvidia"

# unsupported card    #VideoRam    131072   

# Insert Clocks lines here if appropriate

EndSection

この辺を一生懸命読んでみたけど、結局よく分からなかったデス(笑)

http://forums.gentoo.org/viewtopic-t-722498.html

こちらのブログ参考にさせていただきました。

http://blog.tamarin.jp/?eid=1206590

私は、キーマップの設定ででハマることが分かっていたので最初からgmome入れてしまった。

ここで設定!

Keymap 

あと音量調節ツールが動かなかったのでALSAMIXERにて代用しました。

Alsamixer 

これで連休前に某取締役が貸してくれた、「アフリカの星」というドイツの撃墜王のDVDが見れます!

Desktop_2

Xorg_2

それにしても、xorg-serverの変更は辛いです。この時期gentooを入れるのはちょっと待ったほうが良いかもです。

| | コメント (0) | トラックバック (0)